le MEMO du WEB développeur
••• Wordpress •••  Liste des Mémos, astuces et bonnes pratiques

Wordpress Warning: Cannot modify header information - headers already sent by ...

C'est une erreur qui m'est apparu plusieurs fois après une installation d'extension ou changement de thème.

Je n'ai jamais vraiment compris l'origine mais voici quelques manips qui pourront vous aider, et qui ont marché pour moi :

  • Si le fichier incriminé est wp-config.php, ouvrez ce fichier avec un editeur de texte tel que Notpad ++ et enregistrez le avec l'encodage UTF-8 (Sans BOM) puis remettez le sur le serveur.
  • Si le fichier incriminé est un autre (fichier de l'extension ou du thème), supprimez tous les lignes vides en début ou en fin de ce fichier. 

Donnez moi des retours si possible !

publié le 10/03/2014 par Memo Web
Commenter le Mémo :

Migration d'un site Wordpress : Perte des menus et des widgets
Créer un Shortcode avec Wordpress
Comment laisser l'affichage de the_excerpt() si l'extrait est laissé vide dans l'administration de WordPress
Passer un paramètre variable dans get_template_part()
Appeler un shortCode Wordpress depuis un fichier PHP
Parcourir les catégories des articles de WordPress
Traduction Wordpress de texte affiché par un fichier javascript
Une liste d'articles au hasard dans Wordpress
Ajouter le formulaire de recherche Wordpress en PHP
Configurer le fichier WP-config en localhost
Ajoutez vos propres Mémos sur MEMO-WEB

Il suffit de vous créer un compte sur le site

Vous pourrez choisir un thème parmis l'une des catégories proposées par MEMO-WEB.

Rédigez votre Mémo.
Après validation par MEMO-WEB, il sera mis en ligne.
Ajouter vos Mémos